According to the LTTng documentation before building and installing LTTng following dependencies should be installed first:

  • libuuid
  • popt
  • Userspace RCU
  • libxml2

I’ve checked if those packages are installed:

$ ldconfig -p | grep 'libuuid\|popt\|libxml2' (libc6,x86-64) => /lib64/ (libc6,x86-64) => /lib64/ (libc6,x86-64) => /lib64/

which seems to be so according to the output, but building LTTng failed saying that some of packages below are missing. After some time of struggling it turned out that *-devel packages should also be installed (I guess it depends on distribution or version of CentOS).

So here is a quick summary:

$ yum install libuuid-devel &&
$ yum install popt-devel &&
$ yum install libxml2-devel

Userspace RCU should be built :(

$ cd $(mktemp -d) &&
wget &&
tar -xf userspace-rcu-latest-0.9.tar.bz2 &&
cd userspace-* &&
./configure &&
make &&
make install &&

And then simply follow the documentation and install LTTng-modules, -UST and -tools.